Browse Source

Ah, .fixtures.yml required!

master
Aaron Hicks 6 years ago
parent
commit
0dad8665d1
3 changed files with 8 additions and 4 deletions
  1. 6
    0
      .fixtures.ynl
  2. 0
    2
      .travis.yml
  3. 2
    2
      spec/classes/gpg_spec.rb

+ 6
- 0
.fixtures.ynl View File

@@ -0,0 +1,6 @@
fixtures:
repositories:
stdlib: "git://github.com/puppetlabs/puppetlabs-stdlib.git"
firewall: "git://github.com/puppetlabs/puppetlabs-firewall.git"
symlinks:
gpg: "#{source_dir}"

+ 0
- 2
.travis.yml View File

@@ -1,7 +1,5 @@
language: ruby
bundler_args: --without development
before_script:
- "[ $PUPPET_GEM_VERSION ~> 2.6 ] && git clone git://github.com/puppetlabs/puppetlabs-create_resources.git spec/fixtures/modules/create_resources || true"
script: "bundle exec rake spec SPEC_OPTS='--format documentation'"
rvm:
- 1.8.7

+ 2
- 2
spec/classes/gpg_spec.rb View File

@@ -7,7 +7,7 @@ describe 'gpg', :type => :class do
:osfamily => 'Debian'
}
end
it { should include_class("gpg::install") }
it { should create_class("gpg::install") }
end

context "on a RedHat OS" do
@@ -16,6 +16,6 @@ describe 'gpg', :type => :class do
:osfamily => 'RedHat'
}
end
it { should include_class("gpg::install") }
it { should create_class("gpg::install") }
end
end

Loading…
Cancel
Save